Browser Requirements


Blackboard officially requires Microsoft Internet Explorer (5.2 on Mac, 5.5 or later on PC), Netscape (7.1 or later), or Apple Safari (1.1 or later, Mac only). Recent versions of Firefox and Mozilla will also work.
See the Blackboard End User Configuration Guide.

Additionally, you must have JavaScript, ActiveX and Cookies enabled within your browser. To use the Blackboard Collaboration Tool the Java Plug-In is required, Please note that the Java Plug-In is NOT the same as Javascript, and can be downloaded freely from Sun.
Anyone can test their browser settings by using this interactive browser checker
Please rate the article and leave a comment.; Thank you!

To check if your browser settings are up to scratch, please use our Blackboard Browser Check box on the Help Tab

Tags: browser, internet
Last update:
31-08-2016 14:51
Author:
Helen
Revision:
1.0
Average rating:0 (0 Votes)
 

You cannot comment on this entry

Chuck Norris has counted to infinity. Twice.

Records in this category

Most visited RSS

  1. How do I change my password? (60513 views)
  2. How to view student submissions from the Blackboard Assignments ... (33160 views)
  3. How do I manage/view Turnitin Assignments my students have ... (26920 views)
  4. What is my password? (24734 views)
  5. How can I change my password? (24490 views)
  6. What is my username and password? (23569 views)
  7. Blackboard Mobile Learn (18985 views)
  8. Attaching a file to your journal post (18689 views)
  9. I can't login to Blackboard (18226 views)
  10. Adding Digex Scans to Courses (16475 views)

Tags

Sticky FAQs